Lionel Train Forum - Lionel Trains


Author Topic: Polar Express O-Guage Bass Pro Shop doesn’t run  (Read 67 times)

Hendo2

  • New Member
  • *
  • Posts: 1
    • View Profile
Polar Express O-Guage Bass Pro Shop doesn’t run
« on: December 03, 2018, 01:28:05 am »
We bought this Polar Express O-Guage train set at the Bass Pro Shop a couple years ago. Each year we bring it out to put around the Christmas tree. It is a pain to get it working every year, but this year we’ve been trying for 2 hours and no luck. When we plug the transformer into the wall the red light on the track lights up, the light on the front of the train lights up, but it will not move and the audio sounds don’t work when you press the buttons on the remote. The remote is fine. Any ideas what is wrong? Do we have to lube any contacts as they have never been? Any suggestions would be appreciated. Thanks

Share on Facebook Share on Twitter Share on Google+


 

Related Topics

  Subject / Started by Replies Last post
1 Replies
225 Views
Last post December 23, 2016, 08:36:54 am
by dchampney
1 Replies
193 Views
Last post February 19, 2018, 05:09:05 pm
by djacobsen

Member Photos

Recent Threads

Re: Problem with American Flyer Polar Express Engine by coltstarbucks
December 12, 2018, 04:25:56 pm

Re: Problem with American Flyer Polar Express Engine by djacobsen
December 12, 2018, 01:46:52 pm

Problem with American Flyer Polar Express Engine by coltstarbucks
December 12, 2018, 11:39:54 am

Re: How to keep track from seperating under Christmas 🎄 by TrainLarry
December 06, 2018, 08:56:39 pm

How to keep track from seperating under Christmas 🎄 by Ramman347
December 06, 2018, 03:59:07 pm

Menu

Donate to LTF Here

Lionel Trains

Lionel Train Forum - Model Train Forum

©2012-2017  LionelTrainForum.com